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Zomod is a “Classic” Macintosh program that creates a high-resolution image of
a Zometool model from a string of commands in a text file.  There is also a
companion Ray Tracing program that uses the same model description files to
create Photo-realistic images of Zometool models.  (In Zomod the Zometool
balls are shown without holes in them, whereas in the Ray Tracer the holes are
shown.)  With version 1.5 Zomod now requires the PowerPC processor, and
System Software version 7 or later.  Zomod can also run in emulation mode
under Mac OSX.  This manual assumes that you are familiar with the operation
of the Apple Macintosh computer.  A typical use of the program might go
something like this:
• Start Zomod by double-clicking its icon.  You will see a blank untitled image
window.
• Choose the New command from the File menu to open a new text editor
window.
• Build your model out of Zometool parts while simultaneously typing the
Zomod instructions (described below) into the text editor window.
• Choose the Build Model command from the File menu.
• If there is an error in your input file you will be shown an error message.
When you click the OK button, the text insertion mark (a.k.a. the caret) will be
just after the point where your error occurred.  If your file is OK a “wire-frame”
drawing of your model will appear in the image window, and the text selection
will be where you left it.
• At this point if you want to view and render your model in another program,
you can choose Export OBJ... from the File menu.  Give the file a name and click
OK and Zomod will write out a file in the OBJ format that describes your model.
This file can then be imported into any of the many programs that can read OBJ
files.  If you wish to view your model in Zomod, continue with the next step.
• To view your model from different angles, you can drag the image of the
model with the mouse in the image window. To help keep you from becoming
disoriented, you cannot rotate the model past the ‘north pole’ or the ‘south
pole’.  Alternately you can open the Camera... or Orbit... (or both) dialog boxes
from the View menu, enter the desired view parameters and click the Apply
button or hit the Return key.  The Camera and Orbit dialogs both allow you to



set the view you want of your model, but in different ways.  The Camera dialog
lets you position the camera anywhere in space and turn it any which way.  The
Orbit dialog lets you define a point as the "Center" of your model, how far you
want the camera to be from that point, and in which direction.  When you click
the Apply button in the Orbit dialog the camera always points at the "Center"
point.  In addition the Rotate Left, Right, Up, and Down commands in the View
menu provide you an easy way to "orbit" around your model in five degree
increments.  The camera's Zoom Angle and Roll can only be set in the Camera
dialog.  The zoom angle is the number of degrees visible horizontally in your
image.  The roll is the camera's tilt from side to side.  You can also resize your
image window by dragging the lower-right corner of the window.
• If you run short of memory, you can turn off the 'Blat' feature.  When Blat is
off Zomod draws directly to the window on your screen, but when Blat is on the
program draws first into a block of memory, and only when the drawing is
finished is it 'blatted out' (copied very quickly) to the screen.  This gives a
smoother animation.
• At this point you may wish to change the drawing mode from the Mode
menu.  The program starts in the Wire Frame mode.  The three other choices
available are 1) Solid - which draws a hidden-line image, 2) B&W Coded - which
shows balls and yellow struts in white, blue struts in light-gray, green struts in
dark-gray, and red struts in black with white outlines, and 3) Color Coded which
shows the Zometool parts in their actual colors.  All of these modes take a little
longer to compute, so you may wish to stick with Wire Frame mode until you
have the view set the way you want.
• When you are satisfied with how your image looks, you can save the image or
the model description file.  To save the image, bring the image window to the
front and choose Save from the File menu.  This allows you to name a file to
hold a high-resolution PICT image of your model.  (PICT is a type of image file
commonly used on the Macintosh.)  This is much preferable to taking a "screen
shot" since that would yield a jagged, low-resolution (72 pixels per inch) image.
The PICT files produced by the Save command can be opened and laid out in a
number of programs and printed at the full resolution of whatever printer is
used.  Some programs may have problems reading PICT files correctly, for
example Adobe Illustrator version 7.0 alters the image's colors beyond
recognition.  Other programs do not read high-resolution PICT images correctly.
For example Apple’s SimpleText will show the image at one-tenth its correct
size.  Microsoft Word 98 can read the files correctly.
• To save the model description file, bring the text editor window to the front
and choose Save from the File menu.  To use the file again you can open it
from within Zomod using the Open… command from the File menu.

The Zomod Model Description Language



The program keeps track of a three-dimensional coordinate called the current
position.  At the beginning of each model description file, the current position is
at the origin (0, 0, 0).  Each command begins with a single letter as follows:
B Creates a Zometool ball at the current position.  This command does not

take any arguments.  In Ray Traced implementation, each ball uses
48,844 bytes of memory on the heap (4606 bytes for the zomahedron +
1414 bytes for the pentagonal prism times 12 pentagonal holes + 1062
bytes for the triangular prism times 20 triangular holes + 402 bytes for
the cube times 15 rectangular holes.)

S Creates a strut emanating from the current position, and moves the
current position to the other end of the strut (with Zomod you never run
out of parts!).  This command must be followed by an argument
specifying an axis, a direction, and a length, as described below.  Note
that no matter what you build with Zometool, all the Zomeballs always
have the same orientation.  This is what allows us to use the Zomeball to
define a coordinate system.

M Moves the current position without creating any new objects.  Like the S
command, this command must be followed by an argument specifying an
axis, a direction, and a length.  For symmetrical models, it is often
advantageous to begin with a move command to center the model on the
origin.  That way the model can be rotated while keeping it centered on
the screen.

O Orient the model with the specified axis 'up'.  This command must be
followed by an argument specifying an axis and a direction, but no length.
In the current version, this command applies only to parts of the model
that precede it, so you will probably want it to be the last command in
the file.

F Fast Render.  The Zomeballs are geometrically much more complex than
the struts, and thus they account for most of the rendering time.
However it is usually possible to see the structure of a model from just
the struts.  The F command allows you to generate an image without the
Zomeballs, so you can more quickly set up the camera.  Fast Render is off
by default.  You can turn Fast Render on or off at any point in a Zomod
file by just inserting an F.

The axes and directions for the triangular (yellow), rectangular (blue), and
pentagonal (red) struts are illustrated in the Zomod Axis Guide below.  (We
describe the struts by their shape rather than their color because the shape is
intrinsic to the geometry, while the colors are arbitrary.)  The default
orientation of the Zomeball is with the R3+ axis pointing up, and the R10+ axis
pointing to the right.  The axes for the diamond (green) struts are described by
a letter ‘D’ followed by a two-digit number.  The first digit identifies the
pentagonal axis for the hole into which the green strut is inserted.  The second
digit identifies the triangular axis toward which the strut leans.  The sign for the



axis direction is based on the sign of the corresponding pentagonal axis.  Thus
the valid axis numbers for the diamond struts are:

00 10 21 32 43 54
01 11 22 33 44 50
02 16 27 38 49 55
03 18 29 35 46 57
04 15 26 37 48 59

The length argument is an integer from 1 to 9 inclusive, with 1, 2, and 3
representing the short, medium, and long struts respectively.  The length
argument can optionally be followed by “/2” to indicate a half-length strut.
Thus a length of a/b can be interpreted as tau to the a power, divided by b.
(Note that there is no provision in Zomod for green struts that are the same
length as the blue struts.)  Comments may be inserted in a model description
file by preceding them with a semicolon.  All text from the semicolon to the end
of the line is ignored by the Zomod interpreter.  In addition, all text in between
the symbols #| and |# is ignored.  This can be useful for inserting long
comments, to skip over parts of a model for debugging purposes, or to
generate images of a model at various stages of construction.
Spaces are also ignored except if they occur within a number. (i.e. 10 not 1 0)
Zomod is case-insensitive, in other words upper and lower-case letters are
interchangeable.



Zomod Axis Guide



Here is an example of a model description file for a dodecahedron made with the
short struts:

; Dodecahedron

MT1-2  ; Center the figure on the origin
; Starting with the bottom Pentagon
B SR14+1 B SR12+1 B SR10+1 B SR13-1 B SR11-1
SR3+1 B SR7+1 B SR9-1 B SR2-1
MR2+1 SR6+1 B SR8-1 B SR1-1
MR1+1 SR5+1 B SR7-1 B SR0-1
MR0+1 SR9+1 B SR6-1 B SR4-1
MR4+1 SR8+1 B SR5-1
MR5+1 SR1+1 B SR10-1
B SR0-1 MR0+1 SR13+1
B SR4-1 MR4+1 SR11+1
B SR3-1 MR3+1 SR14-1
B SR2-1 MR2+1 SR12-1

You can use any knowledge you have about the model you are building to check
Zomod file. In the case of the dodecahedron, we know that there are two edges
in each of the fifteen rectangular coordinate axes.  The above model satisfies
that requirement.
Here is an example of a model description file with one diamond strut in each
pentagonal hole.

B
SD00+2 MD00-2 SD00-2 MD00+2
SD10+2 MD10-2 SD10-2 MD10+2
SD21+2 MD21-2 SD21-2 MD21+2
SD32+2 MD32-2 SD32-2 MD32+2
SD43+2 MD43-2 SD43-2 MD43+2
SD54+2 MD54-2 SD54-2 MD54+2



Example of Dodecahedron rendered in B&W Coded mode.



Appendix A - Version History
For version 1.1 June 9, 1998
• Show watch cursor during model building, visibility calculation and drawing.
• Fixed bug in which text could become highlighted in inactive dialogs.
• Fixed bug in which change to "Position" in "Camera" dialog would not update
"Center" field in the "Orbit" dialog.
• Fixed bug in which an image file could be corrupted if memory was compacted
during a file save.
• Modified PICT files so that they open in Simple Text when double-clicked.
• Now writing out PICT files in Version 2 format.
• Increased resolution of PICT file coordinates to 720 pixels per inch.
• Safe file writing so even if power fails during a file save, existing files will not
be damaged.
• Fixed bug in which file creator & signature were not changed when a file was
saved over an existing file created by another program.
• Modified so that visibility calculations are not done when switching
applications, uncovering parts of the picture window, or changing from one solid
view to another.
• Flat shaded color.
• Use binary insertion sort optimized for minimum tree depth - about 3 times
faster than the old linear insertion sort.
• Fixed bug in which background color was not recorded in PICT files.

For version 1.2 March 21, 1999
• Added Export DXF... command to File menu.

For version 1.3 March 7, 2000
• Added Image Size... command to View menu.

For version 1.4 July 6, 2000
• Added the “D” axes, a.k.a. “the green lines”.

For version 1.5 April 15, 2003
• Added the built-in text editor.
• Improved error-handling and reporting.



• Added support for the half-length struts.
• Fixed bug in which some diamond struts did not appear in the correct axes.

For version 1.5.1 May 8, 2003
• Added feature to rotate model about the origin by dragging with the mouse in
the image window.
• Maximum axis length (power of tau) extended from 3 to 9, including half
lengths thereof.
• Fixed bug in which the Save command was deactivated when the image
window was in front.
• Fixed crash bug that occurred when using Save As… on a text file that had
already been saved.


